PyDelphin is a Python library for working with DELPH-IN representations, as well as client interfaces to the ACE processor and web API.

PyDelphin can be installed from the Python Package index as follows:

$ pip3 install pydelphin

But it is recommended to install in a virtual environment for your application. For example:

   1 $ python3 -m venv env      # create a virtual environment
   2 $ source env/bin/activate  # activate the environment
   3 $ pip install pydelphin    # install to the environment
   4 

<!> Note that some distributions do not package venv by default. For Ubuntu (one such example), first do this: sudo apt install python3-venv.

Note that a certain version (or higher) of Python is required depending on the version of PyDelphin. The current versions and requirements are:

Current Version

https://img.shields.io/pypi/v/pydelphin.svg

Python Support

https://img.shields.io/pypi/pyversions/pydelphin.svg

The source code, documentation, and issue tracker are available on GitHub: https://github.com/delph-in/pydelphin

PyDelphinTop (last edited 2020-02-14 06:57:44 by MichaelGoodman)

(The DELPH-IN infrastructure is hosted at the University of Oslo)